View Single Post
  #26  
Old 12-05-2009, 09:25 PM
Mangus Mangus is offline
Registered User
 
Join Date: Nov 2005
Location: the great northwest
Posts: 17
Quote:
Originally Posted by Gee2Fly
Considering the money invested with Knife Edge over the years, I'm entitled to a little abrupt communication.

Also, I have never understood why the interlink controllers need to be registered.
It's a useful means of abating piracy. Consider it a dongle as well as an input device.

In the case of the upgrade, it's how they know you own(ed) the original software. You don't need to have 3/3.5/4/4.5 installed in order to install the upgrade.

Let's keep this thread on point for the install issues from here out.

Last edited by Mangus; 12-05-2009 at 09:28 PM.
Reply With Quote