View Single Post
  #49  
Old 02-08-2007, 12:37 AM
JCHarrist's Avatar
JCHarrist JCHarrist is offline
Registered User
 
Join Date: Dec 2006
Location: Anchorage, Alaska
Posts: 161
I figured it out.

Before you open your .X file from Gmax, you need to set up some import options.

Go to File>Open and set "Files of Type" to "DirectX Model". Then the "Settings" button will become active. Click on it.


An Import Properties dialog box will pop up. Set "Optimize Heirarchy" to NO.


Open your .X file and you will see you still get all the subfolders with the frm- prefix but at least the object names are preserved.


Now go to "Save As" and change "Save as Type:" to Autodesk 3D Studio, then click "Settings" again.


An Export Properties dialog box will pop up. Set Export hierarchy information, Export Lights and Export Cameras all to NO, then save it.


Re-open the file and the subfolders will be gone and the oject names (other than the ~ being changed to a _) are not changed. You can now go ahead and set up your hierarchies in DE as Max describes.


Remember you need to change Export hierarchy information back to YES before you save for the KEX conversion.


Keep in mind this only applies to DE 4.1 and is exactly the same thing we were doing in 3.5, the process has just changed slightly.

Last edited by JCHarrist; 09-28-2010 at 05:26 PM.
Reply With Quote