Go Back   Knife Edge > RealFlight - Current Products > RealFlight G5
Use of this site is subject to our Terms of Use. | Technical Support is available from Great Planes Software Support.

 
 
Thread Tools Rate Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 04-29-2010, 01:34 PM
swanley007's Avatar
swanley007 swanley007 is offline
Registered User
 
Join Date: Jul 2007
Posts: 42
Send a message via AIM to swanley007 Send a message via MSN to swanley007
Exclamation Field Radio Settings - Post Your Success Stories

Hello All,

This post is one that I am creating to help those that are utilizing their own field radios in RealFlight. This post will be similar to the router configurations thread that was started. If you have a successful set-up that is not already here, please feel free to post it, so that other may benefit.

**Please do not turn this thread into a discussion for or against using your own field radio. Everyone is entitled to their own opinions and I do truly respect that, but I feel that this thread could become a resource for those wanting to use their own radios.

Thank You All in Advance!

If you are having difficulty using your own R/C radio through the built in interface on the USB InterLink Controller, here are a few tips that should help you overcome most of the difficulties users encounter:

1. Make sure you radio is set to PPM or FM mode and not PCM. Your radio will NOT work with the built in interface on the InterLink Controller if it is in PCM mode. Refer to your Radio's manual for instructions on how to set your radio correctly to FM or PPM mode.

2. Ensure that your transmitter batteries are fully charged. If your transmitter did not "power up" automatically when the interface cord was inserted, turn the transmitter power "on" at this time.

3. If you are using a transmitter which requires the use of a small "pigtail" adapter ( i.e. Futaba, Airtronics, HiTec, etc.) between the main interface adapter cord and the trainer port on your R/C radio, unplug this "pigtail" from the main interface adapter cord. Firmly re-attach this "pigtail" to the main adapter cord, listening for an audible "click" confirming that a proper connection is completed. Likewise, momentarily unplug the "pigtail" adapter from your R/C radio and firmly re-attach it to your R/C radio.

4. It has to be able to connect to the Interlink controller with one of the adapters( the longer cable ).

5. Please also be aware that there is more to using your own R/C radio with RealFlight than just attaching it to the InterLink Controller with the provided adapter cords. Make sure that you are also "telling" the software what you are doing, since RealFlight has no way of "knowing" when you want to use your own R/C radio instead of the InterLink Controller. Here is how to do this:

6. Once you have your R/C radio properly connected to the InterLink Controller, you will want to start up RealFlight (if it is not already running). Select the "Controller" menu, then click"Select Controller". From the "Select Controller" window select your transmitter not Currently, you should have "InterLink Controller (Joystick Mode)" selected. "Joystick Mode" means that the software is (currently) looking for the InterLink Controller, not your R/C radio (this is the default setting).

7. In the transmitter, ensure that you have a blank model set-up for RealFlight specifically, and that all channel mixing is disabled or inhibited. Also, if you transmitter is so equipped, ensure you are in training mode, and/or software radio.

__________________
Don't Look Back, Something May be Gaining!!
Reply With Quote
 

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:27 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.