Go Back   Knife Edge > RealFlight - Current Products > RealFlight 9
Use of this site is subject to our Terms of Use. | Technical Support is available from Great Planes Software Support.

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 10-08-2019, 01:31 PM
fgibson's Avatar
fgibson fgibson is offline
Registered User
 
Join Date: Sep 2019
Posts: 53
Tech Support Frustrations

Sent and email to tech support Sunday night. Got a reply at 11:58am Monday. Not too bad.

I responded at 1:36pm Monday, almost 24 hours ago and no TS response yet.

I was so excited to purchase RF9 because I really felt it would help me with my flying skills...especially having been diagnosed with Parkinson's Disease about 18 months ago.

I am so disappointed and frustrated with the amount of time I have wasted trying to troubleshoot this program. The members of this forum are knowledgeable and very helpful but it seems like RF is just extremely prone to problems.

I would expect that as long as RF has been around, they would have figured out how to solve some of these issues that are ongoing...like theD3DERR error, the issues with DirectX, etc.

I bought this program to help me fly better, not to spend hours updating drivers, uninstalling updates, etc. I don't have any other "games" so maybe this is just par for the course. It's just not at all what I expected. Is this normal in the gaming world?

I'm not giving up on it yet because I don't give up easily...but I'm close.
Reply With Quote
  #2  
Old 10-08-2019, 01:39 PM
BrokeDad's Avatar
BrokeDad BrokeDad is offline
Registered User
 
Join Date: Dec 2014
Posts: 2,090
It's tough to make something that works fine on every single system given the number of possibilities. For the most part it works out of the box on the majority of computers. It even does fine on my all-in-one Dell with built in graphics.
Reply With Quote
  #3  
Old 10-08-2019, 01:58 PM
fgibson's Avatar
fgibson fgibson is offline
Registered User
 
Join Date: Sep 2019
Posts: 53
Quote:
Originally Posted by BrokeDad View Post
It's tough to make something that works fine on every single system given the number of possibilities. For the most part it works out of the box on the majority of computers. It even does fine on my all-in-one Dell with built in graphics.
I understand there are a lot of systems out there. I get that. But, if it runs fine for most people, then tech support should have plenty of time to help the few of us that are having issues.

To me, waiting 24+ hours to get a TS response to an email is not customer friendly. And, I can't find a phone number for TS. That is frustrating as well.
Reply With Quote
  #4  
Old 10-08-2019, 03:51 PM
technoid's Avatar
technoid technoid is offline
Registered User
 
Join Date: Oct 2014
Location: Texas
Posts: 6,343
Quote:
Originally Posted by fgibson View Post
I understand there are a lot of systems out there. I get that. But, if it runs fine for most people, then tech support should have plenty of time to help the few of us that are having issues.

To me, waiting 24+ hours to get a TS response to an email is not customer friendly. And, I can't find a phone number for TS. That is frustrating as well.
Try here... then click RC Support.

https://www.horizonhobby.com/content...der-contact-us

Here's the phone number that's on the RC Support page.

Call: 877-504-0233
Monday - Friday: 8 A.M. - 6 P.M. CST
Saturday: Closed
Sunday: Closed
Reply With Quote
  #5  
Old 10-08-2019, 06:12 PM
fgibson's Avatar
fgibson fgibson is offline
Registered User
 
Join Date: Sep 2019
Posts: 53
Quote:
Originally Posted by technoid View Post
Try here... then click RC Support.

https://www.horizonhobby.com/content...der-contact-us

Here's the phone number that's on the RC Support page.

Call: 877-504-0233
Monday - Friday: 8 A.M. - 6 P.M. CST
Saturday: Closed
Sunday: Closed
Thank you. I spoke to someone who seemed very knowledgeable about RF. She said my issue could be anti-virus software and suggested I do a complete uninstall and reinstall with anti-virus turned off. Will do that tonight and see what happens.
Reply With Quote
  #6  
Old 10-11-2019, 11:16 PM
fgibson's Avatar
fgibson fgibson is offline
Registered User
 
Join Date: Sep 2019
Posts: 53
Turning off anti-virus did not help. Also tried installing RF download instead of from DVD.

Sent screenshots to software tech at Horizon. Apparently, they (techs at HH) had never seen this issue before. I have to admit I was impressed with the tech I talked to...very interested in trying to resolve issue.

Today I found a newer driver for the gpu but that didn't help either. Not sure what to try next. I think I will uninstall the gpu drivers and remove the card. Then reinstall. Not sure what else to try.

Flying only at 3D airports since photo fields are too blurry.
Reply With Quote
  #7  
Old 10-12-2019, 01:19 AM
TomC TomC is offline
Registered User
 
Join Date: Feb 2009
Posts: 477
I hope you resolve this problem and I'm sorry that it is not something easy to resolve. Good luck resolving this! This is a user forum, not a support forum btw.
__________________
Custom built gaming desktop; i9 9900k (water cooled) oc to 5ghz, gtx 1080 ti (from my previous Alienware AGA), 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd. Asus ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Asus vg248qe 1080p 144hz gaming monitor, Oculus Rift cv1 w/2x sensors.
Reply With Quote
  #8  
Old 10-12-2019, 04:22 PM
fgibson's Avatar
fgibson fgibson is offline
Registered User
 
Join Date: Sep 2019
Posts: 53
Quote:
Originally Posted by TomC View Post
I hope you resolve this problem and I'm sorry that it is not something easy to resolve. Good luck resolving this! This is a user forum, not a support forum btw.

Sorry if I broke the rules and posted a tech support question. I honestly did not know I was outside the lines of what can be discussed. My apologies to you and all the other folks that have offered assistance.

Hopefully I can soon resolve this issue and be just a "user". That certainly is the goal.

Take care
Reply With Quote
  #9  
Old 10-12-2019, 05:19 PM
TomC TomC is offline
Registered User
 
Join Date: Feb 2009
Posts: 477
Maybe a better PC would help? Hopefully RF support will eventually get you going. Good luck.
__________________
Custom built gaming desktop; i9 9900k (water cooled) oc to 5ghz, gtx 1080 ti (from my previous Alienware AGA), 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd. Asus ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Asus vg248qe 1080p 144hz gaming monitor, Oculus Rift cv1 w/2x sensors.

Last edited by TomC; 10-13-2019 at 01:02 AM.
Reply With Quote
  #10  
Old 11-04-2019, 11:07 PM
stevet1 stevet1 is offline
Registered User
 
Join Date: Nov 2019
Posts: 3
Quote:
Originally Posted by fgibson View Post
Turning off anti-virus did not help. Also tried installing RF download instead of from DVD.

Sent screenshots to software tech at Horizon. Apparently, they (techs at HH) had never seen this issue before. I have to admit I was impressed with the tech I talked to...very interested in trying to resolve issue.

Today I found a newer driver for the gpu but that didn't help either. Not sure what to try next. I think I will uninstall the gpu drivers and remove the card. Then reinstall. Not sure what else to try.

Flying only at 3D airports since photo fields are too blurry.
I am having the exact same problems you are and tech support has had me jump through the same hoops. Nothing has worked. My program crashes after seconds to a minute of play. I'll try tech support again tomorrow. They never called me back as promised either.
Reply With Quote
  #11  
Old 11-08-2019, 12:27 PM
fgibson's Avatar
fgibson fgibson is offline
Registered User
 
Join Date: Sep 2019
Posts: 53
Quote:
Originally Posted by stevet1 View Post
I am having the exact same problems you are and tech support has had me jump through the same hoops. Nothing has worked. My program crashes after seconds to a minute of play. I'll try tech support again tomorrow. They never called me back as promised either.
Actually I was happy with the TS person I talked to on the phone. I think calling is better than email but some techs seem more interested than others in looking for solutions beyond the normal ones.

One thing I thought about a few days after I resolved this issue is that (as I recall) I was writing a file in Photoshop with RF open at the same time. I wonder if that screwed something up because they were competing for the graphics processor. Since then I avoid having Photoshop and RF open at the same time. No more problems since then.

Good Luck!
Reply With Quote
  #12  
Old 11-08-2019, 01:22 PM
12oclockhigh 12oclockhigh is offline
Registered User
 
Join Date: Apr 2009
Posts: 4,018
HH/KE/RF should consider offering paid technical support. Higher level of technical expertise and better problem solving.

The way it is now, one tech support call could cost them more than the price of the software and hardware. Today, you cannot expect everything for free.
Reply With Quote
  #13  
Old 11-08-2019, 01:45 PM
Flapper Flapper is offline
Registered User
 
Join Date: Mar 2005
Posts: 185
Two items:
1. What was meant earlier is that this is pretty much a user forum. While RF staff do occasionally respond, it's not the official way to get tech support. That said, there are many users here that may have a good shot at helping you fix an issue. It never hurts to ask, as you did.
2. So, what was the fix? Just the potential conflict with Photoshop, or did you have to do something else to resolve it?
Reply With Quote
  #14  
Old 11-08-2019, 06:54 PM
fgibson's Avatar
fgibson fgibson is offline
Registered User
 
Join Date: Sep 2019
Posts: 53
Quote:
Originally Posted by Flapper View Post
Two items:
1. What was meant earlier is that this is pretty much a user forum. While RF staff do occasionally respond, it's not the official way to get tech support. That said, there are many users here that may have a good shot at helping you fix an issue. It never hurts to ask, as you did.
2. So, what was the fix? Just the potential conflict with Photoshop, or did you have to do something else to resolve it?
See this thread for what I did to fix my problem:

http://www.knifeedge.com/forums/showthread.php?t=34014

Would RF entertain adding a forum for tech support? That way those who wanted to help would have a place to do that without invading non-tech support forums.
Just a thought.
Reply With Quote
  #15  
Old 11-08-2019, 07:32 PM
12oclockhigh 12oclockhigh is offline
Registered User
 
Join Date: Apr 2009
Posts: 4,018
I have been here for many years, I don't think KE wants to tech support the software. The publisher has always done that. It would require a big change to the business relationship. Customers are a PITA most of the time. That is just the way it is. (those are my words not KE)

Quote:
Originally Posted by fgibson View Post
Would RF entertain adding a forum for tech support? That way those who wanted to help would have a place to do that without invading non-tech support forums.
Just a thought.
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 03:21 AM.