Go Back   Knife Edge > RealFlight - Discontinued Products > RealFlight G4
Use of this site is subject to our Terms of Use. | Technical Support is available from Great Planes Software Support.

Reply
 
Thread Tools Rating: Thread Rating: 8 votes, 5.00 average. Display Modes
  #31  
Old 11-16-2008, 02:11 AM
clammster clammster is offline
Registered User
 
Join Date: Nov 2008
Posts: 1
Having the same problem on a dell lat d620

updated video driver no luck
downgrade to 4.0 it works
updated directx to 10, 4.0 still works
updated to 4.5, still doesn't work

GRRR.

Called tech support, left message, no call back.



Quote:
Originally Posted by cjshaker
I'm getting the same error, D3DERR_INVALIDCALL File: .\DXEffect.cpp Line: 836, on my Windows Vista laptop when attempting to launch RealFlight G4.5. The error happens continuously.

RealFlight G4 ran fine on this laptop.

Please find attached the screen shot of the error message (borrowed from another poster) and my support information.

Thank you,
Chris Shaker
Reply With Quote
  #32  
Old 11-16-2008, 09:07 AM
jeffpn's Avatar
jeffpn jeffpn is offline
Registered User
 
Join Date: Mar 2005
Location: Beavercreek, OH
Posts: 18,386
Clammster, Please look on the very last page of threads in the G4.5 discussion forum. You'll find a thread that I started called 'Asking for help? Read this. (Search my posts I've started to find it, as well.) Here it is.This post used to be a sticky, until it was determined that KE would rather have RF users call tech support, instead of letting other users try to help with people's problems. Follow the instructions in that thread, and post that file hear. Incidentally, when you call GP tech support, call during normal business hours. I have never been disappointed by them.
Reply With Quote
  #33  
Old 11-17-2008, 06:24 PM
Phreddy Phreddy is offline
Registered User
 
Join Date: Nov 2008
Posts: 2
Thanks

Quote:
Originally Posted by jeffpn
phreddy, no can do. It's your video card. I'm in the same boat with my laptop. I've heard a fix may come.

Appreciate your comeback.

I guess I'll have to be satisfied with running it on the new desktop as it runs there. Would've been nice to take it in the RV, but 4.0 will have to suffice. Once again, appreciate the comeback... Phreddy
Reply With Quote
  #34  
Old 11-17-2008, 06:44 PM
1RookieFlyer 1RookieFlyer is offline
Registered User
 
Join Date: Nov 2008
Posts: 5
i had that problem and went to a site from searching for dll errors and downloading dll 36 it solved my problem
Reply With Quote
  #35  
Old 11-18-2008, 01:59 PM
jeffpn's Avatar
jeffpn jeffpn is offline
Registered User
 
Join Date: Mar 2005
Location: Beavercreek, OH
Posts: 18,386
The above mentioned fix will not work on the Intel video cards in question.
Reply With Quote
  #36  
Old 11-18-2008, 02:02 PM
opjose's Avatar
opjose opjose is offline
Registered User
 
Join Date: Nov 2005
Location: Third rocky planet.
Posts: 13,220
Quote:
Originally Posted by HuckD
Mine has the "Mobile Intel(R) 945 Express Chipset Family" video card. I guess that the same one you're referring to. Maybe there'll be a fix soon........

Huck
While that may be possible, don't hold your breath for it.

The minimum specifications changed for G4.5 which put the "integrated" chipsets outside the envelope.
__________________
Quote:
Newbies please click here for important instructions about forum posts: CLICK ME!
Reply With Quote
  #37  
Old 11-20-2008, 05:55 PM
bigbird07 bigbird07 is offline
Registered User
 
Join Date: Jan 2008
Posts: 9
Same Here

One of my old flying buddies ask me to help him get the new updated to 4.5. After going through the process we ended up with the:

D3DERR_INVALIDCALL
DXEffect.ccp
Line 836 & 896 Loop

It requires a force quit to escape.

He has a Compaq Presario SR5350f with Vista home premium. This is a desktop machine so after reading here I was surprised that it would have a mobile graphic's card. G4 runs great. 4.5 not so much...

I pasted the system info into a note pad file and attached it.

I have reverted him to G4 and everything is back to normal.

Thanks
bigbird
Attached Files
File Type: txt RF sys info.txt (268.7 KB, 9 views)
Reply With Quote
  #38  
Old 11-20-2008, 07:56 PM
Yaff's Avatar
Yaff Yaff is offline
Registered User
 
Join Date: Nov 2008
Posts: 196
New victim of the infamous d3dx9_36.dll error 126 message here
Running XP SP3 on AMD Quad Core and Radeon HD4800 serie

Installed G4 fresh from CD (purchased today)
Updated to 4.50.025 (before running G4 for the first time)

Crash with error above.
Got latest and greatest DirectX for XP (9.0c August 2008 redistribuable)
Reinstalled DirectX

WORKS FOR ME!

Now I can launch in 4.5
Reply With Quote
  #39  
Old 11-22-2008, 09:34 AM
Brownie433 Brownie433 is offline
Registered User
 
Join Date: Oct 2008
Posts: 7
Unhappy I just upgraded and receive this exact error.

I just upgraded from G4 to G4.5 from the Real Flight Launcher. When I attempt to run it I get the missing DLL error.

As requested my info is attached.

Hope a resolution can be made, I was really looking forward to the better landing and ground handling characteristics of this version.

Thanks,
Mike
Attached Files
File Type: txt RfG45DllErrorDiag.txt (184.9 KB, 5 views)
Reply With Quote
  #40  
Old 11-22-2008, 09:51 AM
jeffpn's Avatar
jeffpn jeffpn is offline
Registered User
 
Join Date: Mar 2005
Location: Beavercreek, OH
Posts: 18,386
Your specs indicate Directx 9.0 compliance, not 9.0c. I don't know if that's the problem, but the fact that your card is integrated is not a good thing when it comes to 3D apps. Do you have a video card slot on your motherboard? Your card is much older than G4.5 would like, and an upgrade would sure help.
Reply With Quote
  #41  
Old 11-22-2008, 10:51 AM
Brownie433 Brownie433 is offline
Registered User
 
Join Date: Oct 2008
Posts: 7
Thumbs up

Quote:
Originally Posted by jeffpn
Your specs indicate Directx 9.0 compliance, not 9.0c. I don't know if that's the problem, but the fact that your card is integrated is not a good thing when it comes to 3D apps. Do you have a video card slot on your motherboard? Your card is much older than G4.5 would like, and an upgrade would sure help.
Thanks Jeff. I have been wondering whether the vid card is just not up to 4.5 and maybe 4.0 was the limit of the card.

I may need to upgrade to a hotter 8x AGP card with 512MB. The AGP 8x cards are getting fewer and farther between, and I don't see a complete system overhaul in my future yet.

Btw, the card is not integrated.

I wonder if 9.0 Dx is the issue vs. 9.0c.

Thanks,

Mike
Reply With Quote
  #42  
Old 11-22-2008, 11:11 AM
jeffpn's Avatar
jeffpn jeffpn is offline
Registered User
 
Join Date: Mar 2005
Location: Beavercreek, OH
Posts: 18,386
My mistake. I saw "Integrated RAMDAC", and only noticed "Integrated."
Reply With Quote
  #43  
Old 11-22-2008, 11:36 AM
Garcon31 Garcon31 is offline
Registered User
 
Join Date: Nov 2008
Location: Massachusetts
Posts: 22
Smile Direct X issue - I had it too

I have installed 4.5 on several machines and ran into this issue every time. I checked in advance and confirm that I already had Direct X 9.0c installed on these machines. In each case I cancelled the Direct X install and got the "can't find..." result being reported.

For me the solution was simple enough -- I ran the Direct X installer from the 4.5 disc and it fixed things. I still had 9.0c and the error went away.

BTW - all of my machines are modest except one. I tried a P3 900mhz (unusable), a P4 1.2 mhz (pretty good), under Vista on a 1.8 Core 2 Duo with soldered on video (unusable so far as the video driver keeps crashing), and finally a Intel based Mac Book Pro running Windows XP (best results).

Hope this helps.

Last edited by Garcon31; 11-22-2008 at 11:38 AM. Reason: add OS statement
Reply With Quote
  #44  
Old 11-22-2008, 05:08 PM
opjose's Avatar
opjose opjose is offline
Registered User
 
Join Date: Nov 2005
Location: Third rocky planet.
Posts: 13,220
Quote:
Originally Posted by bigbird07

He has a Compaq Presario SR5350f with Vista home premium. This is a desktop machine so after reading here I was surprised that it would have a mobile graphic's card. G4 runs great. 4.5 not so much...

Thanks
bigbird
A lot of buyers never bother looking or know nothing about video specs...

These are the people that go into a store and will gladly sacrifice video performance in the name of lower cost.

The Integrated video adaptors are basically sold to that crowd.

However with Desktop machines all is not lost!

Usually the integrated video is an almost freebie toss-in.

But desktop machines almost always feature PCI-E video slots that will accept the faster and better video adaptors...

Upgrade yours... you can get some fantastic pricing ( approx $150.00 ) on very capable adaptors now, which will run G4.5 and other programs with aplomb.
__________________
Quote:
Newbies please click here for important instructions about forum posts: CLICK ME!
Reply With Quote
  #45  
Old 11-22-2008, 10:33 PM
Vernski Vernski is offline
Registered User
 
Join Date: Feb 2008
Location: 8mi nw of CDA Idaho
Posts: 10
erorr problem

"OK" upgrade to What?? and where do you get it at?? And this was not in the Almighty "Search" feature! ---Vernski
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:47 AM.