9.5 installs but wont run, Unexpected Error has occurred

LinuxGuyGary

New member
Ver 9.5

Using with interlink Elite, install went fine no issues, initial splash screen opens, but clicking Run Realflight program, It does not run, and returns error message " An Unexpected error has occurred. Would you like to send an error report to Knife Edge Software? which I have done several times. Computer is AMD Ryzen 7 3700X 8-Core Processor 4.05 GHz 16GB mem. NVIDIA GeForce GTX 1660ti. I probably should also mention, I have the latest BIOS, latest video drivers direct from Nvidia, and all current on windows updates.

Was asked by Horizon Hobby support, to run Direct X diagnostics and send the log, which I did. they then said .. USB voltage is out of spec, but testing proves otherwise @ 5.03. I also tested with a USB powered hub, and a USB switch:
  • USB Powered hub, measures 5.25v same error message
  • Direct to PC measures 5.03v same error message
  • 4 way USB switch measures 4.59v same error message
I have tried both front and rear USB2 and USB3 ports with the same result. there are at least 2 different USB chipsets on the PC. but I get the same result in every case. See attached USB hub list.

Sooo.. current system with a decent graphics card and enough memory. What else do I try?
 

Attachments

marcushh777

Well-known member
Your 4 port usb switch is out-of-spec. Is it supposed to be powered?

Have you tried a powered usb hub ( 4 port ) ?

I would have to do more testing that just voltage ... you need to take several voltage readings with varying safe current loads to determine what's going on with your 5v supply... but I can tell you that often PCs have substandard usb voltage sources; I almost always recommend powered usb hubs for those cases.

Do you have on-board video also... AMD or Intel ? I am not familiar with your processor, just make sure you're not using the on-chip video if it has it... called an APU. Make sure with DX Diagnostics that its using NVidia.


marcus
 

N8LBV

Member
Potential wild goose chase.

Not likely that the USB voltage is truly out of range.
Get clarification from Horizon on where and how they are determining this.
Try the Interlink and software on another computer however possible.
Rule out that the Interlink device itself is not a problem.
Unplug every USB device and any hubs of course.

Run the software without the Interlink. And see if you get the same exact error at runtime.
Also see if it will start up with a generic joystick/Gaming controller installed/plugged in.
RF 9.5 works with other controllers.

Getting more extreme-
Clean install video drivers.
Remove any questionable software (antivirus/antimalware) that might interfere.
Factory reset the motherboard/bios settings.
And fresh install Windows 10 on a test hard drive and Realflight to rule things out.
 

N8LBV

Member
Furthermore did you install from the web download? and all up to date on Realflight?
From your post I can't tell if you already did this or if you are trying to install from disk or what.
 

mrgames99

New member
Same issue. This is total nonsense. For $200 the thing doesn't work out of the box. Very very frustrating. Return policy is a joke too. So I'll have to dispute on my credit card. Windows 10, latest drivers. Intel processor, ASUS R5 230 Series graphics, 16 RAM and 733GB free disk after install.
 

Bill Stuntz

Active member
R5 is an AMD GPU. Current AMD drivers don't work with DirectX9. If you search this message board there are dozens of threads that document this. Some old drivers work, but I don't remember the version numbers of the ones that work. I know they're documented on here somewhere.
 
Top