Controller's Right Joystick Not Working

BarryTBH

New member
The right joystick of my RF Basic controller is causing this weird glitch where in the program it just tilts all the way to the left. The controller had no issues when I used it on a Windows 8.1 machine but then I plugged it into my main windows 10 machine and it's getting the glitch.

A few years pass and I've since re-imaged my main computer (still has windows 10) but the problem persists. I don't have access to any windows 8.1 machines anymore so I can't really test it, but back when I initially came across the problem I went back to the windows 8.1 machine and it worked fine. I don't think it's a hardware issue on the computers side, I think it might have something to do with windows 10 perhaps.

I have tried a number of solutions: calibrating, reinstalling etc. It's kind of hard to resolve this issue since I've searched so much on the problem but no one except one person on this website seems to have a similar problem.

I'd really like to get back into this program especially since I'm working on a video that involves compositing a model airplane onto footage and I want a good reference to track the motion of the model. As well as some sound samples. If no solution comes up I can still run and use the program, this issue just renders any actual flying futile, really sucks because I adore this program.
 

BarryTBH

New member
https://imgur.com/K77uGGC

^ This is what the program thinks I'm inputting, when in reality I'm not touching the controller.

https://imgur.com/zdDdGyQ

^ This is what the calibration window is showing, the Z and Y axis are registering as half-way, which is accurate because that's where the joysticks sit in real life, however it seems to simply not detect the X axis, and so keeps it's value at 0. However, something strange is that the X axis flutters about as if it DOES detect it but there's some software issue preventing it from doing anything, like how when playing some video games the windows cursor is moving in the background but is constantly resetting to the center of the screen as to prevent the player from clicking out of the game.
 

DJ Planet

New member
Hi, think my copy was doing the same.
Win 10
Find usb settings
Create new
Calibrate that
But move aileron then elevator
Then throttle
Ignore rudder
On my dx8e,I used a basic plane model.
When I re loaded rf8, I only had to reverse my rudder and everything works
 

Phil Johnson

New member
Could be dirty pots in the sticks. I had a problem with glitching with mine so I sprayed the pots with alcohol spray (I don't have any switch cleaner). Both sticks seem fine now. That was a year or two ago now.
 
Top