Jitter in the transmitter while running ardupilot simulation

ksgaur

New member
Hi,
I am running the simulation of a tailsitter model using mission planner simulation. The connection is working fine. But as soon as I arm the model the rc values starts to jitter. The jitter problem does not occur when I run any other default model of realflight 8 and no simulation.

I have also observed that the jitter increases with the angle of the model and sometimes during level flight.

I have tried the following without any success:
-Tried to disconnect the transmitter from realflight and running it through mission planner to check if the transmitter itself is not responding properly. I have also tried to use another joystick but no success.

-Tried running the controller on a Linux system and connecting through a network to identify if it is due to mission planner. Found out that that there are random nav commands on the graph even without moving transmitter sticks.

-Tried running in auto mode and guided mode to eliminate transmitter values, but still the same result.

Please help
 
Top