Objects not show in the simulation screen

richrfl

Member
When I select either trees or Country objects, I can see them in the edit window from the pilot, but when I save and enter into the simulator, they are not there. The field is a modified Photofield. However, although invisible, the objects are there, as my plane crashes against them. in other words, I have "ghost objects" in the simulation.
Anyone has any clue why this happens with this only two type of objects, but not with any other type?
Thank you
 

adrenoline 60

New member
Sorry its been a long time since I had G 4.5 installed.
So I don't remember if the Environment Editor changed with RF 7.5 & 8. The Aircraft editor did.

In the Environment Editor:
The Folder Listing Window, Contains the Objects, that Populate your Field.

Folders, have Property Parameters that apply to all of the Objects,(Children) located within that folder.
Clicking on a Folder will bring up Setting Options, in the Property's Window, that apply to, that folder.

Depending on how the folder is set up, eg Depth Buffer's,
Placing a Scenery Object in this folder, the Object May be Invisible in the program, but still be Collidable if you hit it.

Individual Objects,(Children) located within Folders, Also can be clicked on, to set up Individual Property Parameters, Unique to that object. Some of these settings, Can override the general settings of the folder.


Scenery Objects can be hidden behind Depth Buffers and appear Invisible, but still be Collidable.
Objects and Depth Buffers can be set up to be Collidable, or Not.

In the Properties Window, clicking on each Parameter, will bring up a description, of what each represents, along with setting, options.
Minimum, Maximum, Default values, etc.
 

Attachments

Last edited:

richrfl

Member
I entered the hay bale ok, and that has the properties as shown in your attachments. So far, so good.
Now, the tree does not have any of the properties, (check my screenshot), and, of course does not show in the simulator screen.
 

Attachments

adrenoline 60

New member
Try this as a Test. This is what I did.
Load Stock, Sod Farm.
Enter Environment Editor.
Expand Objects Folder +
R Click on Depth Buffer Objects Folder. Delete Object. (deletes entire folder)
L Click on Objects Folder, to Highlight, and make this, the parent folder. (children, subject to its property parameters)
This will also activate the Object Palette Window, to make selections from.
From the Object Palette Window, select:
Dead Ringer Pylon Inflatable. Place it at the end of the runway.
Trees>American Elm. Drag it, onto the Runway, to the Left of the Heli Spawn.
Country Objects>Circle Hay Bail. Drag it to the Right of the Pilot Spawn next to the Runway.
Note: No other changes were made for this example.
Exit Editor, Via File, Exit to Simulator.
Rename Airport Sod Farm Test.

On my My Machine, the Dead Ringer Pylon, Tree, and the Hay Bale, All show, and are Collidable.
 

Attachments

Last edited:

richrfl

Member
I followed your instructions to the point, but still the trees are not showing. See the attachments.
Unless you have any other idea, I guess I will need to uninstall/re install G5?
 

Attachments

adrenoline 60

New member
Before doing a Uninstall, Reinstall, you might try a System, "Restore Default".
This option should be available, through the Launcher, Additional Options>Restore Defaults
Just Curious, you said G5. You did have all the latest updates available/installed, for G5.5, Correct?
 

richrfl

Member
Yes, I updated to the latest version of G5 (5.50.034). Will do the restore default and see what happens. Thank you for the lead.
 

richrfl

Member
adrenoline, I regret to say that the repair process did not help. I un-installed/installed but still the hay bale shows and the tree doesn't. I give up. There is something wrong either with the program I have or in my computer. I was able to do all this modifications in my older PC, but no more. Therefore, I either live with it or upgrade to R8 and go from there.
Thank you for your help anyway.
 

adrenoline 60

New member
If your willing to try one more test.
I picked this Photo Field from the swaps.
Swap Pages > RealFlight G5.5 > Airports > Custom Photofields
It has a row of 9 trees 1 fern cluster, on the opposite side of the runway.
The tree objects, show as, added, via the editor, from stock files. (that should exist in your program)

Here's the link:
Mackillop Sporting Field1_PI
https://www.knifeedge.com/forums/downloads.php?do=file&id=15384

See if the tree line, shows up, on your machine.
If they DO show, try Adding a tree.

Note: Program screen shot, was done at manual zoom, zoomed out - full
 

Attachments

richrfl

Member
I will try that one, but I am not holding my breath. I opened one of the non photofield that came with the CD, which has trees added in the original, and they did not show in the simulation. I am starting to think that there is something really wrong in the General Settings. Tomorrow I will review that again, and play some enabling/disabling/performance and any other parameter that can eventually be blocking the trees from showing.
 

richrfl

Member
Gents, my apologies.
It seems that at some given time, I mistakenly change the Trees view settings to NO. When I found that a stock airfield did not show the trees either, I start to suspect that something was wrong in the settings, and this morning I went back to re-check all settings and found that the Trees view was NO.
I am very sorry to have taken your time for such a 101 mistake. When I was asked at the very beginning if this setting was YES, I answered it was, as that was the first thing I checked, but it looks that I focused in the setting above the trees. The other thing that help to the confusion is that the default setting is NO, and therefore I didn't re-check the setting after the repair or re-install, assuming it should be YES.
Anyway, the problem is solved. Thank you again.
 

adrenoline 60

New member
Glad to hear you got it figured out.

Just For the Record,
Depending on computer resources available, RealFlight program, Will, Automatically make settings adjustments.
The program tries to optimize Physics, over eye candy.


This is a Quote from RealFlight 7.5 Handbook:
Improving RealFlight 7.5 Performance-
During installation, RealFlight 7.5 analyzes your computer’s hardware specifications. RealFlight 7.5 then tries to optimize its configuration to best take advantage of that hardware, and achieve the best possible performance.

If your CPU and or GPU isn't keeping up, and your frame rates are low, the next time you open the Program, RealFlight may, Automatically, try to Optimize your settings,(for your own good ;) ) To reduce the load.
Trees and Clouds, are usually the first things, to get Disabled.

Here's a Test you can do. Make note of your settings.
Simulation>Settings>+ Graphics>Hardware. Verify whether your running on GPU or CPU.
Simulation>Settings>+ Graphics>Quality
Main Menu View>Scenery. (Clouds-Trees etc) Choose All
Note: Enabling/Disabling Clouds - Trees in Main Menu View, also changes them in, Settings>Graphics>Quality, and vice versa.

Shut down, RF program, Restart.
Open a 3d field.(Flight School) Note, if clouds and trees show. If not enable, in View.(All)
Shut down RF, Right Click Launcher Icon, choose: Run with Graphics Processor>Integrated Graphics.
When the program opens, to Flight School, there is a Good Chance, Clouds, and Trees, will be Disabled.
You Can go back to Main Menu, View, and Manually Enable them again.

In the Handbook there is a section on "Graphics" that breaks down settings and their effect on performance.
There is also a section called Improving RealFlight Performance.
 
Last edited:

richrfl

Member
Thank you a lot!!
This is really VERY GOOD stuff. (I think this also shows that is always helpful to READ the manuals. Lol :eek:)
 
Top