Problems connecting for online updates? Read this.

Ryan Douglas

Administrator
Staff member
The errors you report are something I would expect to happen intermittently if/when something happens to the connection rather than happening consistently. Did you retry the update? If so, did you receive the same errors? If so, do they always occur at the same point, such as while downloading a certain file?
 

alcoxy

New member
Still Problems

Yes i retried the update and i also tried reinstalling and am still having the same problems. They always occur at the same point, before any files are even tried to be downloaded or my registration is tried to be sent, both fail every time, always.
 

MHildebrand

New member
Ryan Douglas said:
The Launcher from version .410 is now available for direct download. The file is a self-extracting setup that will copy the latest Launcher to the correct location for you.

This version of the Launcher fixes several problems that kept some customers from performing online updates. The problems affected users with a Direcway satellite internet connection and some users inside a network. The usual KEError in this case was 12228.

Of course, if you can't connect for updates in the first place, you can't download the Launcher that will fix your problem, so now you can download it here. Just save it to your local drive somewhere convenient and then run it. You won't need to change any settings during the installation.

When finished, run the Launcher and attempt online registration and updates. Please let us know your results with this version of the Launcher! If you still have problems, please tell us what happens and exactly what error messages you receive.
How does one learn the version number of the Launcher? All I see on startup is RealFlight G3: 3.50.065?
 

jeffpn

Well-known member
Go through your start menu to run the launcher program. Hit additional, then technical support. After a while (the launcher will assemble your specs) The screen will open up, giving you some diagnostic or test choices. I saw the launcher version in the lower left hand corner.
 

Helinewbie

New member
Registration Problems for Realflight G4

Hi All,

I'm turning to this forum as my last resort to get help in registering my copy of Realflight G4. :confused:

I've read some solutions recommended for Registration connection errors for Realflight G3.

KEError 12228: HTTP response is missing an expected header
KEError 21023: Unable to Register: Client/Server transaction failed.

But I am running Realflight G4 and I'm getting the same above error messages.

Is there a patch or fix I can install to fix this? :confused:

How can I get the updates if I'm not able to register? :confused:

Appreciate if anyone can help advise.

P.S. previous emails to rfsupport@greatplanes.com have not been answered for over a week(automated or otherwise). :mad:
 

Helinewbie

New member
Manual Update for my Realflight G4

Finally got through to Tech Support.

Found out that my registration was logged on their database, but for some reason my installed copy of G4 was having connection problems with the Server and giving me all these errors, which in turn prevented me from getting updates online.

The Support Technician I spoke to was friendly and patient, and it was a pleasure talking to him. :D

Pity I couldn't give the company any points for the initial attempts of trying to contact them via email though. I suspect their SPAM filters dump almost all emails coming from hotmail accounts. :rolleyes:

The workaround given was an email sent to me with a link to the latest update for a manual download and install.

Hope they can find the root cause and resolve this issue.

I'm grateful for the help received here. Thanks! :D
 

jengelh6471

New member
Well how come they can' post the link? I have been going around in circle because of the same problem with no help from both companies.
 

jeffpn

Well-known member
They can't post the link because the update file for one user may not be the same update file for another user. It all depends on what your current version is, which may be earlier than someone else's. So you would miss all the files between your starting version and his starting version. And that leads to errors that GreatPlanes would rather not deal with.
 

edoad

New member
The fix don't work. Contacted support and they gave a work around update but can't tell me why I can't register.
 

Ahint

New member
Hello,

I just finished struggling with the registration process under VISTA premium.

The original message came up as "socket error .... 12228".
Downloaded the update version as in the 1st post and and the error message remained.

Checking the file version, I noticed that LauncherSetup.exe did not update "launcher.exe".
So I renamed laucher.exe to launcher.old in the "program files\common files\KnifeEdge" folder.
Ran once more LauncherSetup.exe and finally it works...
 

srydel

New member
I was able to connect turning off my anti-virus software. I use bit defender software on vista premium.
 

BentUser

New member
Can anyone tell me what the current version of 3.5 is? I finally found my install discs to set up my new machine but don't what version it's up to.

And along those lines if I need to update/upgrade is there somewhere I can download directly from and then bring it home to my desktop? I don't have an internet connection so I was going to use some of my office's bandwidth to get the updates :)

Thanks,
j
 

jeffpn

Well-known member
BentUser said:
And along those lines if I need to update/upgrade is there somewhere I can download directly from and then bring it home to my desktop? I don't have an internet connection so I was going to use some of my office's bandwidth to get the updates :)

Thanks,
j
Contact tech support. They can give you a link to update your software. http://www.knifeedge.com/forums/showthread.php?t=22007 Alternatively, installing Expansion Pack 4 will update you to the latest available version, I believe.
 

edmoor

New member
dont do it

blade said:
I don't have a problem connecting!

I have problem with the size of the down loads, they're too big!

Make them smaller, or make them so you can down load them and then exicute them when you finally have the whole thing so it doesn't corrupt G3 during the down load if the down load fails.
dont do the download...........it will cause a corrupt error to appear evrytime you open the rf sim......nothing but a joke!!!
 

nikole957

Banned
Ryan Douglas said:
This is a Windows problem. Here are a couple of threads that deal with this topic:

Thread #1
Thread #2
I installed v410 yesterday. I thought I'd pass on some observations. I've noticed that all the airports' wind settings are now at zero instead of whatever speed they used to start out at, with the exception of the S.N. Cliff. Also, the wind direction changes direction wildly during flight (even though the wind speed isn't changing). In addition, my computer's mouse cursor seems to lag quite a bit when the photofields, and some of the other airfields are loaded.
 

Er Sunil Kumar

New member
Upgrade 3.5 to higher

Dear All,

I want to upgrade the software of real flight simulator, please guide me.

my friend by fraud has register it in his name.

regards

Sunil




The Launcher from version .410 is now available for direct download. The file is a self-extracting setup that will copy the latest Launcher to the correct location for you.

This version of the Launcher fixes several problems that kept some customers from performing online updates. The problems affected users with a Direcway satellite internet connection and some users inside a network. The usual KEError in this case was 12228.

Of course, if you can't connect for updates in the first place, you can't download the Launcher that will fix your problem, so now you can download it here. Just save it to your local drive somewhere convenient and then run it. You won't need to change any settings during the installation.

When finished, run the Launcher and attempt online registration and updates. Please let us know your results with this version of the Launcher! If you still have problems, please tell us what happens and exactly what error messages you receive.
 

jeffpn

Well-known member
To upgrade to RF6, you'll need to buy the RF6 upgrade. You do have the RF Interlink controller, right? That's all you need.
 
Top