Rans Chaos S9

BrokeDad

Well-known member
For anyone who wants it this is my electric version with the altered red CS on it PilotAt6 did originally. This is an EA because it's the one WITHOUT the collision mesh. It won't sink in the ground but it won't work with some versions of RF (Pretty sure RF-X needs the collision mesh). I have tested it with RF8 and RF9 to be ok. I fixed all the errors except for the ~CS_Spinner. It'll show fine but you'll still get that message.

All the controls will work on any controller. Brakes are on up elevator and the canopy is on the left top three way switch if using the Interlink DX or Interlink Elite.
 

Attachments

Ghost129er

Active member
Very cool work as always. This motivates me and makes me want to finish my Rans S9 for IL-2 1946, but at the same time, I'm so damn lazy and demotivated with other things I just don't feel like doing it, glad you did at least, very well built so far for a beta (from the looks of it) and love this community for all putting their part and mucking around with the aircraft files in Beta stage.
 

PilotAt6

Well-known member
BrokeDad Replied:" It's a double sized AV version of the electric one I did. "

Flies smooth and graceful ... good job !
But I'm doing something wrong importing.
There isn't a CS associated with the plane. I just imported, no questions were ask ... but it's just white. When I select a CS I get a message about textures. So how do I fix this, and what procedure am I doing wrong importing ... because it happens to me on other variations occasionally.
Thanks!
 

technoid

Well-known member
BrokeDad Replied:" It's a double sized AV version of the electric one I did. "

Flies smooth and graceful ... good job !
But I'm doing something wrong importing.
There isn't a CS associated with the plane. I just imported, no questions were ask ... but it's just white. When I select a CS I get a message about textures. So how do I fix this, and what procedure am I doing wrong importing ... because it happens to me on other variations occasionally.
Thanks!
When that happens do you "exit" realflight and start it up again? I've had to do that before and it fixed the problem. Not always but I've had that fix a problem when I imported something and it wasn't right.
 

BrokeDad

Well-known member
New beta to try, rescaled the MMVS to match MMR and applied collision mesh to model.
TGA has changed slightly (tail feathers and cowl)
Now the Chaos S9 imports into RFX as well.
I get the following four errors on import. I'll see what I can fix. Also take a look at the outer edges of the ailerons. There has always been a kinda weird black area on them. Really appreciate the work. I'm not trying to be critical just figure you'd want to know things we notice. I can see from the nose we'll need to redo CS's to match the new beta.

I added a shot of it flying out over my world headed to the bridge and marina.
 

Attachments

Last edited:

technoid

Well-known member
Now the Chaos S9 imports into RFX as well.
Ha.. Are you still flying that version of RealFlight that KnifeEdge discarded. :) Just kidding I know both of us still love it. In fact I like RF-X so well I found a new Interlink-X controller on Ebay and bought it. I'm also doing some special work on the Tractor 120 so all the openings in the Fuselage will show this time so you can train to your hearts content. Please tell your wife a family in Texas is praying for her.
 

BrokeDad

Well-known member
I've been working on the Tractor 120 so I haven't tried the latest beta yet. I was also waiting for ASJ to fix the errors you reported earlier too.
Yeah I fixed all the frame errors on the latest Beta but now the pivot points for the canopy frame and glass are messed up. Of course the only way to fix those is in 3DS Max or whatever he is using. So I won't post anything more until he has a chance to fix that too.
 
Top