Real Flight 7.5 installation problems

mspence

New member
I just purchased Real Flight 7.5 w/interlink elite. Installed the program which completed successfully. Installation of Direct X completed without a hitch. When I try and start the launcher (from the desktop) I get over, and over again a message telling me to plug in the controller. If I press OK nothing happens, if I press cancel, I get the start screen which asks for serial numbers, uninstall, and tech support. There are other options, but they are not highlighted, and cannot be selected.
My computer has Windows 8.1, and exceeds all the requirements to install. Anybody have any ideas as to my problem?
 

opjose

Well-known member
The first times you run Realflight you must do so in Administrative mode.

Find the launcher icon, and right click on it, then select "run as administrator".

This will bring up the launcher.

Plug the Interlink directly into a USB port on the computer.

Open the Devices and Printers page ( the launcher is still active ) and make sure that Interlink Elite appears. You should hear a distinctive "USB GOOD" tone when you do so. If the Interlink Elite does not appear try a different USB port in the computer. If that still does not work, go into the device manager while the Interlink is still plugged in and "uninstall" any unknown USB device. Then unplug the Interlink ( listen for the removal tone ) and try again.

Once the Interlink is found run Realflight from the launcher. You SHOULD be prompted for the serial numbers.

Enter the serial numbers paying special care not to mistake zeros and the letter "O" and the numeral one with the letter "I".

One Realflight comes up calibrate the Interlink and EXIT immediately.

Now run the launcher again normally.
 

mspence

New member
Thanks for the info. I tried installing on another computer with the exact same results. I talked with tech support, and it turns out the problem is a bad controller.
They were very helpful, sent me a shipping label to return it while we were on the phone. Normally they would wait to get defective controller before sending a replacement, but I just gave them the tracking number showing it was shipped and they shipped me one out, two day air. The tech I spoke with was very professional, and quite knowledgeable. Even though it's a little bit of a hassle, I feel better knowing how they stand behind there product. Once again, thanks for your help!
 

opjose

Well-known member
Glad you got it sorted out.

There were reports of a bad run of Interlinks. Sorry you got a hold of one.

Welcome to the addition!
 

Kinverflyer

New member
Just purchased and started the install which crashed part way through, it now wont let re-install saying it detects a previous installation. I have delete the Realflight and Knifedge folders which has made no difference please advise.

Forgot to mention running Windows 10
 
Last edited:

12oclockhigh

Well-known member
It would probably be best if you contacted tech support... look for the link in the grey bar at the top of each forum page. "....Read This"
 

themightypatman

New member
A friend of mine has G4 with interlink elite controller, and had purchased and installed 7.5 wireless (the one with the drone on the box cover) with hopes of still using the interlink elite controller with it. After installing and going through all the proper steps, RF 7.5 is not recognizing the controller, however the G4 still does and it works fine. I looked at the troubleshooting section of the RF7.5 launcher and it shows the codes for the simulator, the USB wireless plug, AND the interlink elite controller. We tried plugging the elite into all the other USB ports but still get the same result. We had borrowed a transmitter with SLT and that worked fine, but he doesn't want to have to purchase a new transmitter to solve the problem. Is there any way you can help us with what to try next? Thank you in advance for your time and help.
 
Top