Real Flight 9.5 always starts in VR Mode

DDM.Dieter

New member
I have Real Flight 9.5 and I also have an HTC Vive headset with Steam VR. I would like to use my CD version of Real Flight ONLY in desktop mode. Realflight starts VR mode immediately and when I quit Steam VR, Real Flight is terminated. I cannot set any start options for Real Flight in Steam VR, and neither can I in Real Flight. I have to pull out the cables from the VR so that I can use Real Flight in desktop mode and my VR equipment remains switched off. I find it useless if the VR equipment is switched on when I play Real Flight on the desktop. But plugging the cables out and in is not a sensible solution. I should be able to choose whether I want to use Real Flight in the desktop or in VR mode. I use the translator and hope everything is translated correctly.

Best regards

Dieter
 

nigelh

New member
Similar:
I have an Oculus and RF9.5 insists on starting it up but at least the headset won't go live unless you put it on.
I tried it and you get a fuzzy little thing that is my helicopter but you can't see it clearly enough to determine the heading so it's not very useful yet. I'd love to be able to find a 'Use VR' check box in the configuration so I could uncheck it as Oculus usually comes up in sell something mode and I have to manually switch it to something else or it wants to mess things about.
Sorry I can't help.
 

DDM.Dieter

New member
It calms me down that I'm not the only one with this problem. But even with the Vive, I only see a cluster of pixels in VR only a short distance away and it is actually unplayable in VR mode with the Vive resolution. Maybe it's compatible with newer VR headsets that have a higher resolution. On Steam there was the possibility to set start options for games, now not anymore. Thanks for your contribution, even if you couldn't help! :)
Best regards
Dieter
 

TomC

Member
Best way I've found to avoid my Oculus Rift from starting up is to make a copy of my RF9.5 desktop shortcut, right click on it/Properties, and then add -novr to the top target line. Then rename it RF9.5 No VR. Works well for me.
"C:\Program Files (x86)\RealFlight9\Launcher9.exe" -novr
 

DDM.Dieter

New member
That also works with the Vive! :))

And Real Flight support couldn't help me!
That can't be true!

Thanks for this great hint, problem solved!
 

TomC

Member
It works! You are a hero Sir.
Where did you find that?
Glad it's working ok for you. I actually got this tip from Jeremy from KE a few years ago regarding RF8. I cannot seem to find the post anymore, even with search.
 

technoid

Well-known member
Glad it's working ok for you. I actually got this tip from Jeremy from KE a few years ago regarding RF8. I cannot seem to find the post anymore, even with search.
I never posted but I knew I saw a command line parameter to start without vr and looked for it a lot but I couldn't find it either. But I thought Ryan posted it so I was searching all of his posts, so thanks for letting us know who posted that fix.
 

TomC

Member
I never posted but I knew I saw a command line parameter to start without vr and looked for it a lot but I couldn't find it either. But I thought Ryan posted it so I was searching all of his posts, so thanks for letting us know who posted that fix.
Ya, even searching Jeremy's posts I could not find this post. No big deal. Maybe I'll just take credit for it now with RF9.5, lol!
 
Top