RealFlight 7.5 - Program wont detect controller


New member

I have a problem with my Interlink controller not being detected by RealFlight. Nothing i do seem to be able to fix it. It worked the first time i installed the program but after that it won´t detect it im on Windows 10

1. Tried other computers, no problem. Works every time
2. Checked under hardware and the controller is there
3. Tried to reinstall program, dont work (even in new folders)
4. Deleted all entries in Device manager to get the computer to reinstall the controller
5. Tried to delete every entry of the program in computers registry to see if that would help, nothing

Anyone got any suggestions? Next option i have is to reinstall the complete computer which i don´t want to!


Active member
Glad you made it over here from RCU Forums! (I referred you!)

I'm running RF 8.5, which allows for any USB game device to be used. Uninstalled RF 7 long ago. So I can't be too much help in trying to diagnose. Try a search here (even for results from much older versions) for clues on things you can try.

Not sure how much of an issue with 7.5 it may be, but one common current solution to this problem is to try different USB ports on the PC, or even using a powered USB hub. Some ports just don't have the "oomph" to power the controller. Easy to try.
Last edited: