Realflight 9.5 Anti-Aliasing

vilysakowski

New member
Looking to see if anyone has suggestions to get rid of the jagged edges in RF9.5. I've been trying to adjust the settings in the NVidia Control Panel but nothing seems to improve. I've got an RTX2080 and an Intel i9 processor so I can set everything to the max. Any help would be appreciated.
 

caltain

Active member
You need to remember that the NVidia Control Panel largely defines what the video card will allow to be done, not what will necessarily get used by any particular application.

To adjust the features that RF attempts to use, you need to make your changes in Simulation > Settings... > Graphics > Quality and Graphics > Hardware.

Max the settings there and then go to a field with lots of rendered objects, like the Boneyard or Junkyard.

Load a plane with a gas engine, enable smoke, and see how that system does. I'll be interested to hear the framerate.
 

vilysakowski

New member
Everything is already maxed out in the hardware section. I've got smoke enabled and it has no effect on FPS. I'm averaging about 320 FPS with smoke on.
 

12oclockhigh

Well-known member
I know that this topic has been covered in this forum before. Try using the search engine. Offhand, I don't know the answer. I just remember a discussion a while ago.
 

Ryan Douglas

Administrator
Staff member
RealFlight does not support antialiasing via internal settings. You'll need to use the NVidia control panel to turn it on (and it sounds like you've gotten started there). Once you've done that correctly it does work.

The main thing to know is that you'll need to tell it to override the application settings for certain things. The basic antialiasing and anisotropic filtering, for example, are set to "application-controlled" by default.

You can either do that at the global level, which will affect everything, or by adding RealFlight to the list of programs and tweaking the settings just for it.

In the attached screenshot I have forced antialiasing and anisotropic filtering on as well as cranked up a couple other settings.

Oh, and make sure to actually apply the settings changes!
 

Attachments

vilysakowski

New member
RealFlight does not support antialiasing via internal settings. You'll need to use the NVidia control panel to turn it on (and it sounds like you've gotten started there). Once you've done that correctly it does work.

The main thing to know is that you'll need to tell it to override the application settings for certain things. The basic antialiasing and anisotropic filtering, for example, are set to "application-controlled" by default.

You can either do that at the global level, which will affect everything, or by adding RealFlight to the list of programs and tweaking the settings just for it.

In the attached screenshot I have forced antialiasing and anisotropic filtering on as well as cranked up a couple other settings.

Oh, and make sure to actually apply the settings changes!
Hello Ryan,
Thanks for the reply. I've noticed that the only setting different from mine compared to yours is the Anti-Aliasing FXAA. I had that turned off. However, when I turned this function on in nVidia Control Panel, all of the text in RealFlight became real blurry. It also looked like certain objects became blurry in RealFlight as well. Is this normal or am I missing something here in terms of other settings that need to be adjusted?
 

TomC

Member
Hello Ryan,
Thanks for the reply. I've noticed that the only setting different from mine compared to yours is the Anti-Aliasing FXAA. I had that turned off. However, when I turned this function on in nVidia Control Panel, all of the text in RealFlight became real blurry. It also looked like certain objects became blurry in RealFlight as well. Is this normal or am I missing something here in terms of other settings that need to be adjusted?
FXAA helps some, not all. Probably depends on things like your gpu and monitor. Read the notes about it on your nvidia control panel. If it helps leave it on, otherwise, turn it off. I have it on and with my gtx1080ti I cannot say I notice much difference either way.
 

caltain

Active member
Fast Approximate Anti-Aliasing is a great leap forward for many render-intensive video applications, but it needs to be coded into the game to produce a benefit in speed and graphic quality. The most notable downside it has is a loss of definition in the edges, hence your text fuzzing. If RF hasn't adapted their anti-aliasing code to use FXAA, it won't typically improve your situation.

The foliage density will definitely improve foliage, but not so much with near axial fine lines, which is what AA was created to address. The only solution to stepping of such features is to increase the pixel density to well below the visual threshold and take the exponential processing hit. There's a good reason that games look fantastic and crisp on a phone or pad. They pack a full screen into a much smaller space with pixel density below the visual threshold. It's a new direction in the industry that has only recently become possible on mobile hardware. The hardware always lags and plays catch-up with the graphic demands of users and developers.

Sorry you are discovering that your fantastic new system still has the same limits as your last fantastic system!!
 

vilysakowski

New member
Definitely interesting information! I decided to turn off FXAA as it bugs me when you have blurry text. I set everything to max in the nVidia Control Panel and it has helped a bit with the jagged lines. Graphics are also set to the highest level in RealFlight itself.
 
Top