RealFlight Trainer Edition missing controller choice for Spektrum DXs provided with Habu RTF package

JFD49er

New member
Is anyone else having an issue with this? I first thought I could not switch between flight modes because I hadn't gone through enough lessons. I eventually figured out changing controllers helped some. Then HH Support provided a document which shows how to take an existing Spektrum option and edit it into what I need for the DXs. I was only partially successful with various things I try. I can't get the channels above 4 to setup properly. It is my opinion that HH as the integrator of the E-flight Habu, the Spektrum DXs, and the RealFlight Trainer edition should have ensured a controller option for the DXs. In doing so, newbie's like me would have more confidence in the setup and learn proper habits while training. Anyone else running into this? Help please.
 

whizkidtn

New member
Is anyone else having an issue with this? I first thought I could not switch between flight modes because I hadn't gone through enough lessons. I eventually figured out changing controllers helped some. Then HH Support provided a document which shows how to take an existing Spektrum option and edit it into what I need for the DXs. I was only partially successful with various things I try. I can't get the channels above 4 to setup properly. It is my opinion that HH as the integrator of the E-flight Habu, the Spektrum DXs, and the RealFlight Trainer edition should have ensured a controller option for the DXs. In doing so, newbie's like me would have more confidence in the setup and learn proper habits while training. Anyone else running into this? Help please.
Can you post/attach the document that HH Support provided on how to correct this?
 

whizkidtn

New member
I got this reply on how to fix the simulation to match (mostly) the real DXs radio:
"Thank you for your recent contact with Horizon Hobby's product support.

Once you bind the dongle to the radio launch the software.
Next go into the select controller feature located under "Simulation tab. Click edit. Change channel 6 and 8 by selecting input on the far right, you need to select these channels under the input column then move the switch intended to control these channels.

Don't forget to save the changes under a new name."

This fixes the mode switch (3 modes). The throttle cut works, the dual rates works (only in advanced mode) but I can't get the Panic Button to work. However a work around is to just throw the mode switch back to "Beginner".

Additional note: To use the WS2000 USB dongle you have to hold down the button on it when you first plug it into the PC until an orange LED on it will start blinking (then release the button). You then hold the bind button in on the DXs transmitter and press the DXs power button to turn on the DXs transmitter and start the bind process. Once the orange LED on the dongle goes solid and the orange LED on the DXs is solid, you have bound them together.
 
Last edited:
Top