RF9 Loading Problem

Eddie Brown

New member
I attempting to install RF9 from discs which will be working with a new DX9 TX. This binds ok through the Spektum dongle but after loading the front page the software does not respond and wants to report the problem to Microsoft. I asked Real Flight support for help and they told me to disable Micosoft Defender firewall and reinstall which I have now done four times to no avail. I have reported this to RF and will now have to wait several days to get a response. In the meantime I was wondering if anyone has experienced this problem whether there is anything else I can do. Could the discs be corrupted? I have never experienced this problem before and downloads from Steam have worked perfectly without the need to disable the Firewall
 

BW108

New member
I am having the same problem getting RF9 to run. I have a new computer [3 months old] but it has been running the program without any trouble until today. Is anyone else having problems?
 

Eddie Brown

New member
Thank you for that BrokeDad. I am very tempted but I will persue this further with RF to start with. It is clear that there is a problem that many people are having. Considering the price it really should not be happening.
 

12oclockhigh

Well-known member
Sorry, late to party. Did you use the RealFlight Launcher to 'Restore Defaults"? Usually, the problem relates to Graphics card drivers. Did you try moving ahead or back to a different version of RF9. A Windows update might have caused the problem. Recent update? There are other functions on the Tech Support form that might provide some information. I agree, to giving Tech Support a call tomorrow.
 

Eddie Brown

New member
Thank you for your response 12oclockhigh. I have only just seen it, very interesting. Please forgive me asking stupid questions. I will try Restoring defaults. I am using an AMD Radeon RX 5700 XT which is only 8 weeks old and has performed superbly. I have had no problems running other games programmes or downloading software from places like Steam. I sent another e-mail to RF asking for help but as they took 5 days to answer the first one I assume it will be a few days before I here from them. I would give them a call but I can't find a phone number. I do appreciate your help.
 

Eddie Brown

New member
I have tried to phone Product Support. After 35 mins waiting on the phone with no response I gave up. May be I should give up on the product as well!
 

Eddie Brown

New member
I have now downloaded the software from the link show above by Brokedad. Unfortunately it too will not load but it still has my serial no. showing on the launcher which considering that I had uninstalled the disc copy suprised me. Therefore it did not require me to enter the no. again. I looked at the activation page on the site but you need an activ ation key which I do not have!
It is 8 days since I made my first e-mail request to support and I am no farther forward. I expected based on previous experience that they would have interigated my pc remotely and solved the problem
 

12oclockhigh

Well-known member
I don't know your situation and how you pay for long-distance phone service.
Half-hour is not long during these virus times. Give them a break and try again. I hate waiting on hold just as much as any other, still you shoot yourself in the foot hanging up. Some times they offer a call back. Use it.
 

Eddie Brown

New member
I was not offered a call back facility. They did explain in the recorded messages that a lot of people are working from home which in the main should be manageble with the use of technology especially to a company like Horizon.
 

Eddie Brown

New member
I have downloaded the latest drivers for my AMD graphics card and ensured that windows is up todate. I have downloaded RF9 from the link that you provided Brokedad. However, it still freezes. I am really at a loss as to know what to do.
 
Top