RF9 - Not loading after latest steam update

ribuck

New member
Hi All,
I had been using Steam edition of RF9 no problem and last used it a about 6 weeks ago. I tried launching it today and it appeared to install an update, but after it finished installing the latest update RF9 will no longer launch - it just now hangs on the main menu screen saying "Not responding". I've tried uninstalling & reinstalling - but unfortunately no joy as it just does the same thing.

Anyone else facing this issues or can offer any suggestions ?
 
I'm having the same issue. With 5 hours of playtime on the game so I can't get a refund through Steam. Support has been emailing me for several days asking tons of questions basically implying it's a hardware problem. It's not.

Intel i5-9600k
AMD Radeon 5700 XT newest drivers
16 GB RAM
1080p 144 hz FreeSync monitor

Eats AAA games for breakfast @1080p and RF9 worked fine . . . right until it didn't.

Support has now helpfully referred me back to these forums.

I asked for a direct download key to see if the problem is Steam - which seems reasonable since I can prove I purchased it. Depending on the answer my next step is to dispute it through Amex. Frankly this software wasn't worth $100 when it worked. It really isn't when it doesn't.
 
Last edited:

ribuck

New member
Well Gusty_McCrashington, at least you had a response from support - I emailed them 4 days ago and not a peep out of them. I'm the same, only about 7-8 hours of usage.

P.s. love your forum name - made me chuckle.
 

ribuck

New member
Gusty - you know what - i just noticed that we have 1 thing in common - We both have crappy Radeon 5700 XT's

I just updated my laptop with the latest steam RF9 steam update and that worked fine. My laptop is a new 10th Gen intel chip with the built in Graphics chip - So i could be that the new update has a bug with Radeon 5700 XT cards.

I upgraded from a Nvidia card which was always rock solid and never had issues and this is my second Radeon card in my lifetime and i will never ever get another one as both cards i've had both had loads of driver & crashing issues - never again. Shame i didn't have my old nvidia card anymore to test the theory.

Rich
 

Curmoikie

New member
Well this isn't what I wanted to hear. I've been trying to get RF9 to work on the new PC I built with a Radeon 5700xt but I'm having the same not responding problem. But its only a problem on the new PC. The old hunk of metal PC I have still runs it fine.
 
I am happy to report that an uninstall of AMD Adrenalin and roll back to 20.4.2 fixed this issue for me.

Support was less than helpful, but all of us reporting problems with the same card in the same timeframe pointed right at the driver update being the culprit.
 
Last edited:
Top