Timber downloads

singleminded

New member
Need some help for a newbie...I have 7.5 and I've downloaded several variants of the Timber but keep getting an error message when I try to import...missing the original download....can anyone tell me which one I need? After flying RC for 8 years, the Timber Turbo has become my 'go-to!
 

Mitch58

Member
When you are looking at the Variant scroll down a bit. It should say required... Click on that and you will need to download and import that one first.
 

grooveybf109e

Active member
Need some help for a newbie...I have 7.5 and I've downloaded several variants of the Timber but keep getting an error message when I try to import...missing the original download....can anyone tell me which one I need? After flying RC for 8 years, the Timber Turbo has become my 'go-to!
It might be a "av" for the 9.5 timber, you have to have the original "ea" either stock, or downloaded, it if is the 9.5 timber, I don't think that you can get it, I have 7.5 too, you could copy the link and paste it in the thread.
 

BrokeDad

Well-known member
If you want one Donamy did as a user model you can download it here <-- click . Like mentioned you may be downloading variants for the one KE did and included in later RF versions.
 

Cato Werner

Member
It might be a "av" for the 9.5 timber, you have to have the original "ea" either stock, or downloaded, it if is the 9.5 timber, I don't think that you can get it, I have 7.5 too, you could copy the link and paste it in the thread.
yeah thats the issue, i remember being so angry that it wouldnt work on 7.5 XD. now i have RF 9.5 so im all good
 
Top