TX16s with USB connection as controller

Flapper

Active member
N8LBV - I just duplicated your setup on the Taranis, and it too gave me the 64% centers in RF, even though it appeared to calibrate fine in Windows. I then went in and assigned 3 position switches to channels 5-8, and 2 pos to higher channels. (I could have used knobs or sliders in place of the 3 pos. switches, as I also tested that). It then worked perfectly fine in Windows AND in Realflight.

It appears that first 8 channels really want to have something controlling them. Skipping plays havoc with the calibrations. I did not evaluate whether the center is critical, or it just needs a high and a low. As I've noted before, you can continue on the TX to assign as many switches to high channels (9 and above) as you want, and they will be recognized by Win and RF as on/off buttons. 3 pos will only have one position seen as being "on".
No harm or foul by setting up more channels and switches than you will really map in the controller setup, and just leave the others unmapped.

I'm kind of done testing on my end. Try populating all 8 lower channels with anything, and see if just making them all have something attached as a control settles things down.

BTW - in OpenTX, the order of the list in Inputs has no bearing on the order of channels assigned in the Mixer. It is just a list. All that matters in the Mixer is that you pick something for a channel to work - either a native control, or something from somewhere on the Input list.

If yours does then begin to play nice, I think we have maybe found it - RF 8 really wants all 8 channels to be controlled, and doesn't deal well if it isn't getting full data from the Windows layer. And likely RF 9, being more recent, has had that problem addressed in it's implementation. I won't hold my breath for a retroactive fix, though.
 

hsamuels

New member
Hi N8LBV,

My apologies for the confusion.

I had started from a setup that exhibited the 64% trim problem. Then I reordered the inputs to TAER123456, with each channel passing straight from the input to the mixer. And after the calibration in RF8, the 64% trim problem disappeared. I have no idea why doing what I did fixed the problem - it's just a data point.

It seems like you did the same thing, but with a different order.

Tonight I'm going to get a setup that has the 64% trim problem in RF8, and try it on Heli-X and NeXt.
 

hsamuels

New member
Hi Flapper,

I'm pretty sure that I always had more than 8 channels on my setups. The only reason I'd like to use the USB cable is that the WS2000 has only 8 channels. But some of my setups have the problem, and some don't!

In addition to the test I described above, I'll take a working setup and lop off a couple of channels to see if that breaks it.
 

Bill Stuntz

Member
Do your NON-working setups have ALL of channels 1-8 programmed? Or do they have something like 1,2,3,4,6,7,8,10,12,14 - note 5 is missing. If I interpreted a previous post correctly, extra channels shouldn't matter, as long as 1-8 are ALL programmed.
 

N8LBV

Member
No I have never tried programming all 8 channels (yet)
I was only setting up 123456
I'll try what was mentioned above.
 

hsamuels

New member
Do your NON-working setups have ALL of channels 1-8 programmed? Or do they have something like 1,2,3,4,6,7,8,10,12,14 - note 5 is missing. If I interpreted a previous post correctly, extra channels shouldn't matter, as long as 1-8 are ALL programmed.
That's an excellent question. As far as I can recall, I've always tried more than 8 channels, and all of the first 8 were filled. Those are the only proportional channels, which we need for sticks and any switch with more than 2 positions.

It was pointed out that my default channel order TAER means that one axis of each stick controls axis of the Windows test box. AETR makes it so one stick controls both axes in the test box, and the other stick controls the first two bars in the test box. But I have examples with TAER that work, and others that don't.
 
Last edited:

N8LBV

Member
I am using AETR and have never experienced the two axes or mixed control issue that has been mentioned here. All of mine always come out separate no mixing problems.
Only the 64% at mid stick problem here.
 

hsamuels

New member
The mixed control issue may have been just an incomplete Windows calibration. The 64% trim issue is the main focus here.
 

hsamuels

New member
I have a radio setup that calibrates fine in Windows, and it has the 64% problem in RF8. The same radio setup, with no additional Windows calibration, has no problem with the Heli-X or NeXt simulators.

This looks very much like a bug in RF8. Since some radio setups do work with RF8, I wish we were able to find out from Horizon Hobby what exactly causes the problem, and how to avoid it.
 

N8LBV

Member
I have been trying things until I'm blue in the face and the problem only shows up in RF 8(.5)
Works fine in other sims like AccuRC and Realflight 9.5
Tried setting up all 8 channels and it makes no difference whatsoever.

I found a work-around with the Radio Master see photo.
I simply adjust the servo centers? ( is that what this setting is called? or output centers?) on the TX outputs page until I get 50% in RF 8.5 then I run the calibration.
Weird makes no sense.
I end up with endpoints PERFECTLY at 0 and 100% like they should be and midpoint at 50%
after doing this.
 

Attachments

Flapper

Active member
Interesting - what base configuration (transmitter type) are you using for RF?
Subtrim skews the centering, but doesn't change the Min or Max endpoint. So less range one way, and more the other. RF calibration redistributes everything, and makes it look OK, but you'll have less stick accuracy (fewer steps) in one direction. Better would be to change the center value (the default 1500 number) to change the center point to get to your 50%. Then you'll have equal throw either side of it.
I asked about TX type, as Spektrum and others default to a center value of 1500. Futaba defaults to 1520. That may have some bearing on how much you have to change the center number to get it to work correctly.
Good find!
 

philmoz

New member
On my FrSky QX7S the midpoint issue only occurs if I set a 2 position switch on either channel 6 or 7 in the radio (channel 2 or 3 in the controller calibration screen in RF).

Using a 3 position switch or slider in channels 6 and 7 works fine.
A 2 position switch in channel 5 or 8 in the radio works fine in RF 8.
 
Last edited:

Flapper

Active member
Such a puzzle. I'd be tempted to point a finger at RadioMaster...BUT, while the centering settings N8LBV applied resolved his issue with RF 8, it doesn't explain why exactly the same radio works fine in RF 9.
 

philmoz

New member
To clarify previous post - this is what I see on the QX7S (OpenTX 2.3.11) when calibrating the radio in RF 8.

Using only 3 position switches or sliders - calibration is correct.
Screen Shot 2021-01-23 at 5.19.23 pm.png

Using a 2 position switch on either of these channels - calibration is wrong.
Screen Shot 2021-01-23 at 5.20.41 pm.png
 

Flapper

Active member
To clarify previous post - this is what I see on the QX7S (OpenTX 2.3.11) when calibrating the radio in RF 8.

Using only 3 position switches or sliders - calibration is correct.
View attachment 122926

Using a 2 position switch on either of these channels - calibration is wrong.
View attachment 122927
I confirmed this on my Taranis (both Original, and Plus SE). If testing, don't forget that RF inverts the channel order. So on the radio CH 1 = RF CH 8, CH 2 = RF CH 7, etc. So the errors seen above happen when there is no centering on channels 6 and 7 in the radio.
 

hsamuels

New member
On my FrSky QX7S the midpoint issue only occurs if I set a 2 position switch on either channel 6 or 7 in the radio (channel 2 or 3 in the controller calibration screen in RF).

Using a 3 position switch or slider in channels 6 and 7 works fine.
A 2 position switch in channel 5 or 8 in the radio works fine in RF 8.
You are on to something here! I put 3 pos switches in channels 5-8. If you start the calibration with a 3 pos switch at one extreme, RF thinks it's a 2 pos switch.

On channels 6 and 7, if the 3 pos switch is up (away) when the cal routine tells you to center the controls, the sticks end up at 64%. If one of them starts in the down position, then the sticks read 36% when centered! Channels 5 and 8 do not seem to exhibit this behavior.

And this is a fast thing to test. You just run through the RF cal routine without having to modify the model in the radio, and without having to restart the radio or RF.

I've confirmed Flapper's comment about resolution, or at least something similar to it. With the 6 pos switch on a proportional channel, none of the positions correspond to 50%. If the cal is started with button 4 pressed, the values are 0, 16, 33, 50, 75, 100. Button 4 returns 50%, and 5 and 6 increase by 25% steps. Buttons 1, 2, and 3 divide the space below 50% into 16% steps. So the resolution on either side of center is different if you start the calibration with the control not centered. Something funky happens if cal is started with the switch in position 2 - I think RF knows you are trying to fool it, and sets position 2 to 33%.

In the absence of an actual fix, it seems the way to avoid the problem is to keep 2 pos switches off of channels 6 and 7, and to make sure that the controls are indeed centered (as much as possible) when the cal routine instructs you to do so.
 

Flapper

Active member
And being obsessive about this problem....

I set up 6 models on my TX. The first with centering on all 8 channels (call it the "good" model), then non-centering on ch 5-8 progressively, and finally non-centering on both 6 and 7 (as illustrated above) for the last. (I'm using the TX channel numbers)

I deleted the gamepad in Win, and allowed it to recreate anew. I did NOT calibrate it in Win.
The "good" model calibrated perfectly in RF. The double bad did not work, as expected. I went back to the "good" and it again worked. I did not have to exit from RF, just changed models on the TX and tried calibration again (and didn't save anything in RF).

Then used the following progression:
With USB still active, changed models on the TX, to one with non-centering.
Tested RF calibration.
Went back to the "good" model, and verified it still worked.
Repeat for each of the variations.

From that, I found: non-centering has no impact when placed on CH 5 or 8.
On CH 6 or CH 7, or both at once, I consistently saw the 64% problem on channels 1-4.
 
Top